import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\.AddMyString\\(\".*?\"\\))(?![\\s\\S\\r]*\\1)";
final String string = "var myObject = new MyClass();\n\n"
+ "myObject.AddMyString(\"Test\");\n"
+ "myObject.AddMyString(\"Computer\");\n"
+ "myObject.AddMyString(\"Printer\");\n\n"
+ "[...]\n\n"
+ "myObject.AddMyString(\"Scanner\");\n"
+ "myObject.AddMyString(\"Test\");\n\n"
+ "[...]\n\n"
+ "myObject.AddMyString(\"Computer\");\n"
+ "myObject.AddMyString(\"Speakers\");";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}