re = /(\.AddMyString\(".*?"\))(?![\s\S\r]*\1)/m
str = 'var myObject = new MyClass();
myObject.AddMyString("Test");
myObject.AddMyString("Computer");
myObject.AddMyString("Printer");
[...]
myObject.AddMyString("Scanner");
myObject.AddMyString("Test");
[...]
myObject.AddMyString("Computer");
myObject.AddMyString("Speakers");'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end