#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\s*boolean visible = false)|(.*)"
Local $sString = " type dw_3 from u_dw within w_pg6p0012_01" & @CRLF & _
" boolean visible = false" & @CRLF & _
" integer x = 1797" & @CRLF & _
" integer y = 388" & @CRLF & _
" integer width = 887" & @CRLF & _
" integer height = 112" & @CRLF & _
" integer taborder = 0" & @CRLF & _
" boolean bringtotop = true" & @CRLF & _
" string dataobject = "d_pg6p0012_14"" & @CRLF & _
" end type" & @CRLF & _
"" & @CRLF & _
" type dw_3 from u_dw within w_pg6p0012_01" & @CRLF & _
" integer x = 1797" & @CRLF & _
" integer y = 388" & @CRLF & _
" integer width = 887" & @CRLF & _
" integer height = 112" & @CRLF & _
" integer taborder = 0" & @CRLF & _
" boolean bringtotop = true" & @CRLF & _
" string dataobject = "d_pg6p0012_14"" & @CRLF & _
" end type"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")