import re
regex = re.compile(r"(\s*boolean visible = false)|(.*)")
test_str = (" type dw_3 from u_dw within w_pg6p0012_01\n"
" boolean visible = false\n"
" integer x = 1797\n"
" integer y = 388\n"
" integer width = 887\n"
" integer height = 112\n"
" integer taborder = 0\n"
" boolean bringtotop = true\n"
" string dataobject = \"d_pg6p0012_14\"\n"
" end type\n\n"
" type dw_3 from u_dw within w_pg6p0012_01\n"
" integer x = 1797\n"
" integer y = 388\n"
" integer width = 887\n"
" integer height = 112\n"
" integer taborder = 0\n"
" boolean bringtotop = true\n"
" string dataobject = \"d_pg6p0012_14\"\n"
" end type")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")