package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\s*boolean visible = false)|(.*)`)
var str = ` type dw_3 from u_dw within w_pg6p0012_01
boolean visible = false
integer x = 1797
integer y = 388
integer width = 887
integer height = 112
integer taborder = 0
boolean bringtotop = true
string dataobject = "d_pg6p0012_14"
end type
type dw_3 from u_dw within w_pg6p0012_01
integer x = 1797
integer y = 388
integer width = 887
integer height = 112
integer taborder = 0
boolean bringtotop = true
string dataobject = "d_pg6p0012_14"
end type`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}