import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s*boolean visible = false)|(.*)";
final String string = " type dw_3 from u_dw within w_pg6p0012_01\n"
+ " boolean visible = false\n"
+ " integer x = 1797\n"
+ " integer y = 388\n"
+ " integer width = 887\n"
+ " integer height = 112\n"
+ " integer taborder = 0\n"
+ " boolean bringtotop = true\n"
+ " string dataobject = \"d_pg6p0012_14\"\n"
+ " end type\n\n"
+ " type dw_3 from u_dw within w_pg6p0012_01\n"
+ " integer x = 1797\n"
+ " integer y = 388\n"
+ " integer width = 887\n"
+ " integer height = 112\n"
+ " integer taborder = 0\n"
+ " boolean bringtotop = true\n"
+ " string dataobject = \"d_pg6p0012_14\"\n"
+ " end type";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}