const regex = /\W+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\W+', 'gm')
const str = `Olympia, WA: SLP Full 40 or _Part_ Time`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);