import re
regex = re.compile(r"\W+", flags=re.MULTILINE)
test_str = "Olympia, WA: SLP Full 40 or _Part_ Time"
subst = "-"
result = regex.sub(subst, test_str)
if result:
print(result)