use strict;
my $str = 'Olympia, WA: SLP Full 40 or _Part_ Time';
my $regex = qr/\W+/mp;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";