re = /\W+/m
str = 'Olympia, WA: SLP Full 40 or _Part_ Time'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result