#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.+) ::((?:.|\n.{4}(?<!<!--|[^-\d]...))+)"
Local $sString = "anki-deck::anki-subdeck" & @CRLF & _
"Not captured" & @CRLF & _
"Inline: Front ::a" & @CRLF & _
"Not captured" & @CRLF & _
"" & @CRLF & _
"Not captured" & @CRLF & _
"Multiline: Front ::" & @CRLF & _
"- Back - First line" & @CRLF & _
"- Back - Second line" & @CRLF & _
"- Back - Third line" & @CRLF & _
"<!--ID: 1686385186868--> Obsidian_to_Anki ID line is not captured" & @CRLF & _
"" & @CRLF & _
"Multiline: Front :: Back" & @CRLF & _
"1. First line" & @CRLF & _
"2. Second line" & @CRLF & _
"3. Third line" & @CRLF & _
"*ThisIsNotCaptured*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")