$re = '/(.+) ::((?:.|\n.{4}(?<!<!--|[^-\d]...))+)/m';
$str = 'anki-deck::anki-subdeck
Not captured
Inline: Front ::a
Not captured
Not captured
Multiline: Front ::
- Back - First line
- Back - Second line
- Back - Third line
<!--ID: 1686385186868--> Obsidian_to_Anki ID line is not captured
Multiline: Front :: Back
1. First line
2. Second line
3. Third line
*ThisIsNotCaptured*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);