using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+) ::((?:.|\n.{4}(?<!<!--|[^-\d]...))+)";
string input = @"anki-deck::anki-subdeck
Not captured
Inline: Front ::a
Not captured
Not captured
Multiline: Front ::
- Back - First line
- Back - Second line
- Back - Third line
<!--ID: 1686385186868--> Obsidian_to_Anki ID line is not captured
Multiline: Front :: Back
1. First line
2. Second line
3. Third line
*ThisIsNotCaptured*";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}