const regex = /(.+) ::((?:.|\n.{4}(?<!<!--|[^-\d]...))+)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+) ::((?:.|\\n.{4}(?<!<!--|[^-\\d]...))+)', 'mg')
const str = `anki-deck::anki-subdeck
Not captured
Inline: Front ::a
Not captured
Not captured
Multiline: Front ::
- Back - First line
- Back - Second line
- Back - Third line
<!--ID: 1686385186868--> Obsidian_to_Anki ID line is not captured
Multiline: Front :: Back
1. First line
2. Second line
3. Third line
*ThisIsNotCaptured*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}