using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\(\):]*:\s*(\w*)";
string input = @"savedPosition: comp;
CURLSCHET.NREC ('qwertyuiop'): noprotect;
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}