re = /[^\(\):]*:\s*(\w*)/
str = 'savedPosition: comp;
CURLSCHET.NREC (\'qwertyuiop\'): noprotect;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end