package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\(\):]*:\s*(\w*)`)
var str = `savedPosition: comp;
CURLSCHET.NREC ('qwertyuiop'): noprotect;
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}