#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?!(https?:\/\/[\w.-]+(?:\.[\w\.-]+)+[\w\-\._~:\/?#[\]@!\$&'\(\)\*\+,;=.]+))^.*)"
Local $sString = "sdjhfjksdf" & @CRLF & _
"http://sdjhfjksdf" & @CRLF & _
"http://sdjhfjksdf.com/" & @CRLF & _
"https://sdjhfjksdf.com.ru" & @CRLF & _
"ya.ru" & @CRLF & _
"https://sdjhfjksdf.com.ru/mad?a=b&c=d_dj#uadfd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")