using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?!(https?:\/\/[\w.-]+(?:\.[\w\.-]+)+[\w\-\._~:\/?#[\]@!\$&'\(\)\*\+,;=.]+))^.*)";
string input = @"sdjhfjksdf
http://sdjhfjksdf
http://sdjhfjksdf.com/
https://sdjhfjksdf.com.ru
ya.ru
https://sdjhfjksdf.com.ru/mad?a=b&c=d_dj#uadfd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}