$re = '/((?!(https?:\/\/[\w.-]+(?:\.[\w\.-]+)+[\w\-\._~:\/?#[\]@!\$&\'\(\)\*\+,;=.]+))^.*)/m';
$str = 'sdjhfjksdf
http://sdjhfjksdf
http://sdjhfjksdf.com/
https://sdjhfjksdf.com.ru
ya.ru
https://sdjhfjksdf.com.ru/mad?a=b&c=d_dj#uadfd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);