import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?!(https?:\\/\\/[\\w.-]+(?:\\.[\\w\\.-]+)+[\\w\\-\\._~:\\/?#[\\]@!\\$&'\\(\\)\\*\\+,;=.]+))^.*)";
final String string = "sdjhfjksdf\n"
+ "http://sdjhfjksdf\n"
+ "http://sdjhfjksdf.com/\n"
+ "https://sdjhfjksdf.com.ru\n"
+ "ya.ru\n"
+ "https://sdjhfjksdf.com.ru/mad?a=b&c=d_dj#uadfd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}