#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(s|с).*?(b|б).*?(e|е).*?(r|р|₽)"
Local $sString = "SБЕР6АНК" & @CRLF & _
"❄❄S_B_E R ❄❄" & @CRLF & _
"СБЕ₽" & @CRLF & _
"SBERBANK" & @CRLF & _
"С!БЕРБАНK" & @CRLF & _
"Сбербанк"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")