$re = '/(s|с).*?(b|б).*?(e|е).*?(r|р|₽)/im';
$str = 'SБЕР6АНК
❄❄S_B_E R ❄❄
СБЕ₽
SBERBANK
С!БЕРБАНK
Сбербанк';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);