re = /(s|с).*?(b|б).*?(e|е).*?(r|р|₽)/im
str = 'SБЕР6АНК
❄❄S_B_E R ❄❄
СБЕ₽
SBERBANK
С!БЕРБАНK
Сбербанк'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end