package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(s|с).*?(b|б).*?(e|е).*?(r|р|₽)`)
var str = `SБЕР6АНК
❄❄S_B_E R ❄❄
СБЕ₽
SBERBANK
С!БЕРБАНK
Сбербанк`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}