#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([0-9]+)\s+(.*?)\s*\[([^][]+)]"
Local $sString = "1 Dead Revels [RNA]" & @CRLF & _
"7 Final Payment [RNA]" & @CRLF & _
"1 Ob Nixilis's Cruelty [WAR]" & @CRLF & _
"1 Aid the Fallen [WAR]" & @CRLF & _
"13 Makeshift Battalion [WAR]" & @CRLF & _
"1 Sunblade Angel [WAR]" & @CRLF & _
"34 Trusted Pegasus [WAR]" & @CRLF & _
"1 Orzhov Racketeers [RNA]" & @CRLF & _
"1 Wanderer's Strike [WAR]" & @CRLF & _
"1 Reya Dawnbringer [UMA]" & @CRLF & _
"4 Expansion // Explosion [GRN]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")