// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9]+)\s+(.*?)\s*\[([^][]+)]").unwrap();
let string = "1 Dead Revels [RNA]
7 Final Payment [RNA]
1 Ob Nixilis's Cruelty [WAR]
1 Aid the Fallen [WAR]
13 Makeshift Battalion [WAR]
1 Sunblade Angel [WAR]
34 Trusted Pegasus [WAR]
1 Orzhov Racketeers [RNA]
1 Wanderer's Strike [WAR]
1 Reya Dawnbringer [UMA]
4 Expansion // Explosion [GRN]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}