use strict;
my $str = '1 Dead Revels [RNA]
7 Final Payment [RNA]
1 Ob Nixilis\'s Cruelty [WAR]
1 Aid the Fallen [WAR]
13 Makeshift Battalion [WAR]
1 Sunblade Angel [WAR]
34 Trusted Pegasus [WAR]
1 Orzhov Racketeers [RNA]
1 Wanderer\'s Strike [WAR]
1 Reya Dawnbringer [UMA]
4 Expansion // Explosion [GRN]';
my $regex = qr/([0-9]+)\s+(.*?)\s*\[([^][]+)]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}