using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]+)\s+(.*?)\s*\[([^][]+)]";
string input = @"1 Dead Revels [RNA]
7 Final Payment [RNA]
1 Ob Nixilis's Cruelty [WAR]
1 Aid the Fallen [WAR]
13 Makeshift Battalion [WAR]
1 Sunblade Angel [WAR]
34 Trusted Pegasus [WAR]
1 Orzhov Racketeers [RNA]
1 Wanderer's Strike [WAR]
1 Reya Dawnbringer [UMA]
4 Expansion // Explosion [GRN]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}