re = /I select (.*) and generate Print Statement for \"(.*?)\" with \"(.*?)\"?$/m
str = 'I select PDFPrinter and generate Print Statement for "Deposit Account" with "RandomCustomer"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end