#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).+Exception sending email[\S\s]+?(?=\d{4}(-\d\d){2})"
Local $sString = "2019-03-13 00:33:44,846 [INFO] -: foo" & @CRLF & _
"2019-03-13 00:33:45,096 [INFO] -: Exception sending email" & @CRLF & _
"To:" & @CRLF & _
"[foo@bar.com, bar@bar.com]" & @CRLF & _
"CC:" & @CRLF & _
"[baz@bar.com]" & @CRLF & _
"Subject:" & @CRLF & _
"some subject" & @CRLF & _
"Body:" & @CRLF & _
"some" & @CRLF & _
"" & @CRLF & _
"body" & @CRLF & _
"2019-03-13 00:33:45,190 [INFO] -: bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")