# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".+Exception sending email[\S\s]+?(?=\d{4}(-\d\d){2})"
test_str = ("2019-03-13 00:33:44,846 [INFO] -: foo\n"
"2019-03-13 00:33:45,096 [INFO] -: Exception sending email\n"
"To:\n"
"[foo@bar.com, bar@bar.com]\n"
"CC:\n"
"[baz@bar.com]\n"
"Subject:\n"
"some subject\n"
"Body:\n"
"some\n\n"
"body\n"
"2019-03-13 00:33:45,190 [INFO] -: bar")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.