re = /.+Exception sending email[\S\s]+?(?=\d{4}(-\d\d){2})/m
str = '2019-03-13 00:33:44,846 [INFO] -: foo
2019-03-13 00:33:45,096 [INFO] -: Exception sending email
To:
[foo@bar.com, bar@bar.com]
CC:
[baz@bar.com]
Subject:
some subject
Body:
some
body
2019-03-13 00:33:45,190 [INFO] -: bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end