import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+Exception sending email[\\S\\s]+?(?=\\d{4}(-\\d\\d){2})";
final String string = "2019-03-13 00:33:44,846 [INFO] -: foo\n"
+ "2019-03-13 00:33:45,096 [INFO] -: Exception sending email\n"
+ "To:\n"
+ "[foo@bar.com, bar@bar.com]\n"
+ "CC:\n"
+ "[baz@bar.com]\n"
+ "Subject:\n"
+ "some subject\n"
+ "Body:\n"
+ "some\n\n"
+ "body\n"
+ "2019-03-13 00:33:45,190 [INFO] -: bar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}