#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+(\-\w+){0,2}$"
Local $sString = "nord" & @CRLF & _
"sud-est" & @CRLF & _
"sud-sud-ouest" & @CRLF & _
"nord-est" & @CRLF & _
"ouest" & @CRLF & _
"nord-ouest" & @CRLF & _
"sud" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")