re = /^\w+(\-\w+){0,2}$/m
str = 'nord
sud-est
sud-sud-ouest
nord-est
ouest
nord-ouest
sud
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end