$re = '/^\w+(\-\w+){0,2}$/m';
$str = 'nord
sud-est
sud-sud-ouest
nord-est
ouest
nord-ouest
sud
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);