import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+(\\-\\w+){0,2}$";
final String string = "nord\n"
+ "sud-est\n"
+ "sud-sud-ouest\n"
+ "nord-est\n"
+ "ouest\n"
+ "nord-ouest\n"
+ "sud\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}