package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:(?:MS|MP|PH)[0-9]{5}|Faculty)\b`)
var str = `test MS18057
test Faculty test
test xyzFaculty test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}