$re = '/\b(?:(?:MS|MP|PH)[0-9]{5}|Faculty)\b/m';
$str = 'test MS18057
test Faculty test
test xyzFaculty test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);