re = /\b(?:(?:MS|MP|PH)[0-9]{5}|Faculty)\b/m
str = 'test MS18057
test Faculty test
test xyzFaculty test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end