// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:(?:MS|MP|PH)[0-9]{5}|Faculty)\b").unwrap();
let string = "test MS18057
test Faculty test
test xyzFaculty test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}