using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https:\/\/www\.pinterest\..*?\/([a-z0-9_]{1,30})";
string input = @"https://www.pinterest.com.au/myusername12345";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}