package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^https:\/\/www\.pinterest\..*?\/([a-z0-9_]{1,30})`)
var str = `https://www.pinterest.com.au/myusername12345`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}