re = /^https:\/\/www\.pinterest\..*?\/([a-z0-9_]{1,30})/i
str = 'https://www.pinterest.com.au/myusername12345'
# Print the match result
str.match(re) do |match|
puts match.to_s
end