$re = '/^https:\/\/www\.pinterest\..*?\/([a-z0-9_]{1,30})/i';
$str = 'https://www.pinterest.com.au/myusername12345';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);