#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m){(\s+)?each(\s+)?(.*)\s+as\s+([a-zA-Z._]+)(\s+)?(,(\s+)?)?([a-zA-Z._]+)?(\s+)?(\()?(\s+)?([a-zA-Z._]+(\s+)?)?(\))?(\s+)?}"
Local $sString = "{ each foods as food , key (index )}" & @CRLF & _
"" & @CRLF & _
"{ each foods as food , key }" & @CRLF & _
"" & @CRLF & _
"{ each foods as food }" & @CRLF & _
"" & @CRLF & _
"{each foods as food , ( index ) }" & @CRLF & _
"asdasdsadasd asda sd " & @CRLF & _
"{/each}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")