import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(\\s+)?each(\\s+)?(.*)\\s+as\\s+([a-zA-Z._]+)(\\s+)?(,(\\s+)?)?([a-zA-Z._]+)?(\\s+)?(\\()?(\\s+)?([a-zA-Z._]+(\\s+)?)?(\\))?(\\s+)?\\}";
final String string = "{ each foods as food , key (index )}\n\n"
+ "{ each foods as food , key }\n\n"
+ "{ each foods as food }\n\n"
+ "{each foods as food , ( index ) }\n"
+ "asdasdsadasd asda sd \n"
+ "{/each}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}