const regex = /{(\s+)?each(\s+)?(.*)\s+as\s+([a-zA-Z._]+)(\s+)?(,(\s+)?)?([a-zA-Z._]+)?(\s+)?(\()?(\s+)?([a-zA-Z._]+(\s+)?)?(\))?(\s+)?}/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{(\\s+)?each(\\s+)?(.*)\\s+as\\s+([a-zA-Z._]+)(\\s+)?(,(\\s+)?)?([a-zA-Z._]+)?(\\s+)?(\\()?(\\s+)?([a-zA-Z._]+(\\s+)?)?(\\))?(\\s+)?}', 'mg')
const str = `{ each foods as food , key (index )}
{ each foods as food , key }
{ each foods as food }
{each foods as food , ( index ) }
asdasdsadasd asda sd
{/each}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}