$re = '/{(\s+)?each(\s+)?(.*)\s+as\s+([a-zA-Z._]+)(\s+)?(,(\s+)?)?([a-zA-Z._]+)?(\s+)?(\()?(\s+)?([a-zA-Z._]+(\s+)?)?(\))?(\s+)?}/m';
$str = '{ each foods as food , key (index )}
{ each foods as food , key }
{ each foods as food }
{each foods as food , ( index ) }
asdasdsadasd asda sd
{/each}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);